Apache en MAMP

Apache en MAMP

Apache no funciona en MAMP con OS X Yosemite Developer Preview 5 y 6, cuando inicias MAMP, MySQL arranca perfectamente, pero Apache da un error y esto sucede desde la versión beta 5 de OS X Yosemite. Si esto te sucedió, no estás solo.

La solución es muy sencilla, solo tienes que entrar a “/Applications/MAMP/Library/bin/”, localizar el archivo “envvars” y renombrarlo a “_envvars”.

Con eso MAMP vuelve a funcionar perfectamente en OS X Yosemite y puedes seguir desarrollando tus aplicaciones o webs de forma local.

¿Tuviste este problema con MAMP?

30 comentarios
  1. Peter
    Peter Dice:

    Raro. Reparando permisos con todo cerrado debería de funcionar, aunque esa opción yo no la tengo activa, si encuentro algo también lo comparto. Esta nota y solución no tiene nada que ver con el auto arranque, el problema es otro completamente, así es que habrá que ver alguna solución para eso.

    Saludos.

    Responder
  2. Manu
    Manu Dice:

    A mi tampoco me funciona con 3.0.7.2 y ademas hay aplicaciones que no me arrancan como Sublime, en una instalación de Yosemite desde cero. Desesperaciooooooon …

    Responder
  3. Fred
    Fred Dice:

    Hola yo sigo teniendo problemas para arrancar Apache en MAMP a pesar de haber echo las modificaciones, el problema es que me dice que el puerto esta siendo usado y no se como apagarlo o como proceder, les agradecería si pueden ayudarme,

    Responder
  4. Nacho Ruiz
    Nacho Ruiz Dice:

    Hola a todos. Mi problema no es que no arranque el servidor. Arranca sin problema pero me da errores a cada instante. Tengo que estar refrescando varias veces para que al final me funcione el servidor. Es un engorro. He hecho lo que pone aquí y nada.

    Alguna idea?

    Muchas gracias!

    Responder
  5. Peter
    Peter Dice:

    ¿Refrescando que? El servidor no se refresca, así es que lo que parece que te pasa es que todo funciona perfectamente y no ves tus cambios por el cache. Eso lo supongo porque no explicas nada, ni cuales son los errores que te da, etc…

    Entra a los foros y abre un tema, ahí te ayudo a solucionarlo porque no tiene nada que ver con esta noticia.

    Saludos.

    Responder
  6. ivanra
    ivanra Dice:

    No suelo hacer nunca comentarios, pero llevaba ya un buen rato rompiendo la cabeza de porque no me iniciaba Apache, cuando me tope con este post. Sencillamente genial. Funciono de inmediato. Muchísimas gracias.

    Responder
  7. Dave
    Dave Dice:

    Hola Peter!

    Esta mañana decidí actualizar a yosemite, Pero cuando ví que Apache no iniciaba y no encontraba como solucionarlo… quize matar a alguien… pero gracias a tu post no iré a la cárcel!

    Muchas gracias por la solución!

    Responder

Dejar un comentario

¿Quieres unirte a la conversación?
Siéntete libre de contribuir!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Si tu comentario no aparece o es borrado, la causa es:

• no tiene nada que ver con el tema - MAMP no inicia Apache en OS X Yosemite Developer Preview 5 y 6
• es para promoción
• es para insultar
• es spam

Si necesitas soporte, puedes utilizar los Foros de Ayuda Apple.

Consigue una imagen para tus comentarios en Gravatar.